upgrade from 3.0.4 to 3.0.6

Discussions about RaZberry - Z-Wave board for Raspberry computer
cbnidk
Posts: 29
Joined: 14 May 2015 11:25

upgrade from 3.0.4 to 3.0.6

Post by cbnidk »

Hi
I can't upgrade from 3.0.4 to 3.0.6 when I run
wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash
nothing happens and I have also tried from the web to upgrade it is the same

cb

cbnidk
Posts: 29
Joined: 14 May 2015 11:25

Re: upgrade from 3.0.4 to 3.0.6

Post by cbnidk »

Hi
I have found out that I can't connect to https://storage.z-wave.me/RaspbianInstall

but if I connect to an other ssl site it works

root@raspberrypi:/# apt update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Ign:3 https://repo.z-wave.me/z-way/raspbian stretch InRelease
Err:4 https://repo.z-wave.me/z-way/raspbian stretch Release
server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Reading package lists... Done
E: The repository 'https://repo.z-wave.me/z-way/raspbian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

cb

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Re: upgrade from 3.0.4 to 3.0.6

Post by PoltoS »

Hm... Looks like your system do not accept our SSL. We will update the SSL to fix such a problem

nkraus
Posts: 18
Joined: 07 Apr 2018 17:41

Re: upgrade from 3.0.4 to 3.0.6

Post by nkraus »

I do have the same problem.
Norbert

Zixwater
Posts: 29
Joined: 06 Sep 2014 21:31

Re: upgrade from 3.0.4 to 3.0.6

Post by Zixwater »

PoltoS wrote:
30 May 2020 23:18
Hm... Looks like your system do not accept our SSL. We will update the SSL to fix such a problem
I think your SSL certificates has expired
pi@raspberrypi:~ $ wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb
--2020-05-31 12:47:00-- https://storage.z-wave.me/z-way-server/ ... _armhf.deb
Resolving storage.z-wave.me (storage.z-wave.me)... 46.20.244.36
Connecting to storage.z-wave.me (storage.z-wave.me)|46.20.244.36|:443... connected.
ERROR: The certificate of ‘storage.z-wave.me’ is not trusted.
ERROR: The certificate of ‘storage.z-wave.me’ has expired.

Information about my (new) system(installed from pre-installed image from z-way.me):

Code: Select all

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@raspberrypi:~ $ openssl version
OpenSSL 1.1.1d  10 Sep 2019
pi@raspberrypi:~ $
openssl s_client can only get corret certificate from z-way.met:443 but not from the wildcard subdomains and Chrome is also complaining about insecurity when visiting https://storage.z-wave.me/z-way-server/
Last edited by Zixwater on 31 May 2020 14:10, edited 2 times in total.

timb
Posts: 79
Joined: 03 Jan 2015 00:10

Re: upgrade from 3.0.4 to 3.0.6

Post by timb »

I am having the same problem - I cannot install
Bit of a shame, my SD card blew up and I now dont have a working system
PLease help!

Zixwater
Posts: 29
Joined: 06 Sep 2014 21:31

Re: upgrade from 3.0.4 to 3.0.6

Post by Zixwater »

timb wrote:
31 May 2020 13:52
I am having the same problem - I cannot install
Bit of a shame, my SD card blew up and I now dont have a working system
PLease help!
Depending on your level of expertise you can ignore the ssl certificate and download the latest deb package:

Code: Select all

cd /tmp && wget --no-check-certificate https://storage.z-wave.me/z-way-server/z-way-3.0.6_armhf.deb && sudo dpkg -i z-way-3.0.6_armhf.deb
I cannot answer how your system is installed or problems you might run into =)

timb
Posts: 79
Joined: 03 Jan 2015 00:10

Re: upgrade from 3.0.4 to 3.0.6

Post by timb »

i can get the install script, but the /opt directory is locked down with permissions that I dont know how to get around.
I did get the install script and tried running it, but it didnt complete successfully.

I can try your method, but i am out of my depth there.

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Re: upgrade from 3.0.4 to 3.0.6

Post by PoltoS »

@timb Install it under root

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Re: upgrade from 3.0.4 to 3.0.6

Post by PoltoS »

This is a new global problem with root SSL certificates. One of them expired yesterday morning. We are investigating this, but I hope Raspbian will provide a fix soon.


https://www.opennet.ru/opennews/art.shtml?num=53061
https://news.ycombinator.com/item?id=23362759

Post Reply