Schlage BE469ZP association settings

Discussions about RaZberry - Z-Wave board for Raspberry computer
vlad
Posts: 57
Joined: 19 Oct 2016 04:58

Re: Schlage BE469ZP association settings

Post by vlad »

Well, I see ST is pooling some GE switches, one by one by GET and receiving Report(0) from them before pooling next one.
ST does not pool the lock and rest of my devices.
Moment I operate the lock manually, ST (node 24) sending 2 S2 packages to the lock (node 36)

09/04/2020 19:50:17 29 24 - -69 dBm - - Basic Report (FF)
09/04/2020 19:50:17 24 29 - -58 dBm - - Basic Get
09/04/2020 19:50:17 24 36 - -49 dBm - S2
09/04/2020 19:50:16 24 36 - -48 dBm - S2
09/04/2020 19:50:15 28 24 - -75 dBm - - Basic Report (00)
09/04/2020 19:50:15 24 28 - -57 dBm - - Basic Get
09/04/2020 19:50:14 24 21 - -57 dBm - - Basic Get
09/04/2020 19:50:13 20 24 - -79 dBm - - Basic Report (00)
09/04/2020 19:50:13 24 20 - -57 dBm - - Basic Get
09/04/2020 19:50:12 18 24 - -63 dBm - - Basic Report (00)
09/04/2020 19:50:12 24 18 - -60 dBm - - Basic Get
09/04/2020 19:50:10 16 24 - -74 dBm - - Basic Report (00)
09/04/2020 19:50:10 24 16 - -60 dBm - - Basic Get
09/04/2020 19:50:09 15 24 - -74 dBm - - Basic Report (00)
09/04/2020 19:50:09 24 15 - -61 dBm - - Basic Get
09/04/2020 19:50:08 13 24 - -57 dBm - - Basic Report (00)
09/04/2020 19:50:08 24 13 - -61 dBm - - Basic Get

I do not see lock reply back to ST... how could it be?

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: Schlage BE469ZP association settings

Post by PoltoS »

May be move them closer. May be would also be cool to decode S2 packets - this was not done yet for foreign packets

vlad
Posts: 57
Joined: 19 Oct 2016 04:58

Re: Schlage BE469ZP association settings

Post by vlad »

Well, they are close. ST, Razberry and lock are about couple meters of each other. You can see signal strength -48dBm.
I'm wondering why I cannot see packets going from the lock to ST. But clearly Schlage does communicate with ST.

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: Schlage BE469ZP association settings

Post by PoltoS »

May be a NIF is sent and not a simple packet from Schlage to ST informing about manual operation? But that would be seen in case Schlage is included RaZberry (when primary).

After all, I don't see any reason let explanation how it works... There should be some magic behind... Have you tried to write to Schlage support? I'm curious to know the secret!

vlad
Posts: 57
Joined: 19 Oct 2016 04:58

Re: Schlage BE469ZP association settings

Post by vlad »

Well, maybe ST uses different channels?
I'll try to contact Schlage support but I don't hold my breath. The firmware of the lock was developed by other company.

PS: ST released new firmware with ZWave device messaging loggin thingy. My hub is still to get that new version. Once it gets an update we will see what's going on with Schlage messaging.

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: Schlage BE469ZP association settings

Post by PoltoS »

Schlage informed us on the issue. Please try to do zway.devices[X].Supervision.data.disabled = true and then set the association again. This should help.

The problem was that they ignore Associaiton (LifeLine) in Supervision encapsulation. Definitely a bug, but they assume this is legal.

Post Reply