High CPU Usage since updated to 3.1.0

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Michael S
Posts: 15
Joined: 26 Jan 2020 15:12

High CPU Usage since updated to 3.1.0

Post by Michael S »

Since I updated my Controller (Raspberry2) to 3.1.0 the CPU usage is always about 100% with the z-way-server and reaction of the entire System is very slow.
Anything I can do to bring the usage down?

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: High CPU Usage since updated to 3.1.0

Post by PoltoS »

Please try to disable all apps, restart Z-Way and then enable them one by one to see who is making troubles.

Michael S
Posts: 15
Joined: 26 Jan 2020 15:12

Re: High CPU Usage since updated to 3.1.0

Post by Michael S »

....after waiting a while, CPU usage came down.
One new device I did a new registration and then it took a view hours and CPU usage came down.
Is it possible that the Raspberry 2 just have a bit too less power for all situations?
In total a currently have about 30 devices registered - most of them Water sensors, Thermostats and a view Powerplugs - maily as range extender because of I have a quit big house.

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: High CPU Usage since updated to 3.1.0

Post by PoltoS »

Pi 2 is slow, but I personally went from Pi 1 to 3 only half a year ago, so Z-Way still works on that old hardware too.

There should be some reason for such behaviour. Please check logs during high load, try to find some relation between your actions and high load. This will help us to understand the issue.

Michael S
Posts: 15
Joined: 26 Jan 2020 15:12

Re: High CPU Usage since updated to 3.1.0

Post by Michael S »

...could not really reproduce the situation.
What I did was to add two Steinel Motion detection LED and two Powerplugs.
At that point the devices went so busy. Not this is gone.
Looks stable and all devices reacting quit fast.

Could it be a measure on midterm, to migrate to a new PI4 based rasp and let the existing one active as secondary on a different place where I have anyway a view powerplugs as range extension in the middle?

Michael S
Posts: 15
Joined: 26 Jan 2020 15:12

Re: High CPU Usage since updated to 3.1.0

Post by Michael S »

...now I got it once again after I started "Reorganization" ....

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: High CPU Usage since updated to 3.1.0

Post by PoltoS »

Reorg looks to make huge load. We are checking this

xurg
Posts: 20
Joined: 17 Aug 2020 22:38

Re: High CPU Usage since updated to 3.1.0

Post by xurg »

Any news on this topic? I'm reluctant to update to 3.1.0 because of this.
Raspberry Pi 3 Model B Rev 1.2
Raspbian GNU/Linux 10 (buster)
RaZberry ZW0500 1024/2 SDK: 6.82.01 API: 05.39
Z-Way version v3.1.1 (0b66875)

Post Reply