Page 2 of 2

Re: Unable to update to v3.1.1

Posted: 15 Oct 2020 22:18
by Helleman
enbemokel wrote:
14 Oct 2020 16:50
Are you able to login with a browser to the Z-Way system? Then you may do the backups in expert and user mode,
and you won´t have a problem with the new installation on the raspberry.
But maybe some one has another idea for you loop.
No, not anymore because I have changed internet provider and got a new router with a new password. That is the reason why I am trying to log into the raspberry itself, to be able to update the wifi-settings.
Though, if I just let the raspberry boot and don`t bother to log in, the z-wave.me software runs as it should (of course whithout me able to control it since I cannot log in using a web browser).
On the other hand, would it be possible for me to connect to the raspberry using a web browser if I connect the raspberry to my new router using an ethernet cable? Or does that need configuration on the raspberry aswell?

On another forum they think my raspbian install is corrupted and suggests a fresh install and that I should copy over the necessary files I want to save for the fresh install, using a card reader and windows.
Is this possible? What files should I save?

Re: Unable to update to v3.1.1

Posted: 15 Oct 2020 22:19
by Helleman
enbemokel wrote:
15 Oct 2020 15:55
Hi Polto, this is to easy ;-) .....but often the solution...also he was writing about console, so i think it´s raspberry console.
Correct, raspberry console...

Re: Unable to update to v3.1.1

Posted: 18 Oct 2020 12:05
by PoltoS
Save /opt/z-way-server and /etc/zbw and then re-install z-way (using the script line one our site) to let the install package restore all others boot scripts and other.

Re: Unable to update to v3.1.1

Posted: 19 Oct 2020 16:32
by enbemokel
On the other hand, would it be possible for me to connect to the raspberry using a web browser if I connect the raspberry to my new router using an ethernet cable?

Bit late, but this will work, but you will get a new IP from your Router.

Re: Unable to update to v3.1.1

Posted: 22 Oct 2020 21:33
by Helleman
I actually did a fresh install and needed 4 attempts to get it to work. At the last attempt I used another sd-card and that helped.
So now I am up and running again after I excluded and included all my switches again.

Re: Unable to update to v3.1.1

Posted: 22 Oct 2020 21:37
by Helleman
PoltoS wrote:
18 Oct 2020 12:05
Save /opt/z-way-server and /etc/zbw and then re-install z-way (using the script line one our site) to let the install package restore all others boot scripts and other.
How do I save those? Can I reach them on the sd-card using a card reader and windows? Otherwise that was impossible since there was no chance to get to a console prompt.
Also, the script was impossible to run since I had no console prompt.

However, now that I am up and running again perhaps a backup of those files would be great. How do I save those files? Yes, I am not so experienced with Linux... 😊

Re: Unable to update to v3.1.1

Posted: 24 Oct 2020 02:40
by PoltoS
You had to access your Pi via SSH. If SSH was not possible anymore, you can grab those files by connecting the SD card via a reader to another Linux machine. Windows might not be able to real Linux filesystem

Re: Unable to update to v3.1.1

Posted: 25 Oct 2020 11:18
by andyhilton27
The RaZberry is a tiny daughter card that sits on top of the Raspberry PI GPIO connector not blocking the USB boards. It is powered by the Raspberry PI board with 3.3 V and communicates using UART TTL signals (RX/TX). RaZberry is compatible with all models of Raspberry Pi.