non-sensor Device Status not updating

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
virgahyatt
Posts: 4
Joined: 02 Aug 2015 20:44

non-sensor Device Status not updating

Post by virgahyatt »

So I just started using Razberry and I haven't had any trouble getting my equipment included. However, I have discovered only my sensors actively update in the UI. My locks, dimmers and switches while they respond and if I control them from the UI it will show that status. But if they are controlled locally it doesn't update. I can see in the logs that the data is received but it seems to be ignored for those devices.

Node 9 is my Yale lock and this is an example of the lock being controlled locally if that helps. Thanks.

Code: Select all

[2020-10-17 12:22:50.319] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel1 = 170 (0x000000aa)
[2020-10-17 12:22:50.319] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel2 = 125 (0x0000007d)
[2020-10-17 12:22:50.320] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel3 = 127 (0x0000007f)
[2020-10-17 12:22:50.320] [I] [zway] Job 0x3b (Get background noise level): RSSI Ch#1: -86 dBm, Ch#2: too low, Ch#3: invalid
[2020-10-17 12:22:50.320] [D] [zway] Job 0x3b (Get background noise level): success
[2020-10-17 12:22:50.321] [I] [zway] Removing job: Get background noise level
[2020-10-17 12:23:02.118] [D] [zway] RECEIVED: ( 01 0B 00 04 00 09 02 98 40 AE 00 00 8D )
[2020-10-17 12:23:02.118] [D] [zway] SENT ACK
[2020-10-17 12:23:02.118] [D] [zway] SETDATA devices.9.data.lastReceived = 0 (0x00000000)
[2020-10-17 12:23:02.119] [I] [zway] Node 9:0 CC Security: sending Nonce Report
[2020-10-17 12:23:02.119] [I] [zway] Adding job: Nonce Report
[2020-10-17 12:23:02.120] [D] [zway] SENDING (cb 0xd4): ( 01 11 00 13 09 0A 98 80 04 8F DE 47 40 63 5C 59 05 D4 03 )
[2020-10-17 12:23:02.122] [D] [zway] RECEIVED ACK
[2020-10-17 12:23:02.126] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2020-10-17 12:23:02.126] [D] [zway] SENT ACK
[2020-10-17 12:23:02.126] [D] [zway] Delivered to Z-Wave stack
[2020-10-17 12:23:02.152] [D] [zway] RECEIVED: ( 01 18 00 13 D4 00 00 02 00 AD 7F 7F 7F 7F 01 01 03 00 00 00 00 02 01 00 00 8F )
[2020-10-17 12:23:02.152] [D] [zway] SENT ACK
[2020-10-17 12:23:02.152] [I] [zway] Job 0x13 (Nonce Report): Delivered
[2020-10-17 12:23:02.153] [D] [zway] SendData Response with callback 0xd4 received: received by recipient
[2020-10-17 12:23:02.153] [D] [zway] SETDATA devices.9.data.lastSendInternal = **********
[2020-10-17 12:23:02.153] [D] [zway] SETDATA devices.9.data.lastSend = 43124372 (0x02920694)
[2020-10-17 12:23:02.153] [D] [zway] Job 0x13 (Nonce Report): success
[2020-10-17 12:23:02.153] [I] [zway] Removing job: Nonce Report
[2020-10-17 12:23:02.172] [D] [zway] RECEIVED: ( 01 21 00 04 00 09 18 98 81 B7 4A 61 28 2A D6 C4 4A 21 12 81 D7 A7 04 C0 E7 CE 63 CE 2D 46 24 AE 00 00 77 )
[2020-10-17 12:23:02.173] [D] [zway] SENT ACK
[2020-10-17 12:23:02.173] [D] [zway] SETDATA devices.9.data.lastReceived = 0 (0x00000000)
[2020-10-17 12:23:02.173] [I] [zway] Node 9:0 CC Security: Received a secure message
[2020-10-17 12:23:02.173] [D] [zway] SETDATA devices.9.instances.0.commandClasses.152.data.firstPart = **********
[2020-10-17 12:23:02.173] [I] [zway] Node 9:0 CC Security: passing decrypted packet to application level: [ 71 05 13 01 ]
[2020-10-17 12:23:02.174] [D] [zway] SETDATA devices.9.instances.0.commandClasses.113.data.V1event.alarmType = 19 (0x00000013)
[2020-10-17 12:23:02.174] [D] [zway] SETDATA devices.9.instances.0.commandClasses.113.data.V1event.level = 1 (0x00000001)
[2020-10-17 12:23:02.174] [D] [zway] SETDATA devices.9.instances.0.commandClasses.113.data.V1event = Empty
[2020-10-17 12:23:10.508] [D] [zway] Job 0x3b: deleted from queue
[2020-10-17 12:23:20.321] [I] [zway] Adding job: Get background noise level
[2020-10-17 12:23:20.322] [D] [zway] SENDING: ( 01 03 00 3B C7 )
[2020-10-17 12:23:20.324] [D] [zway] RECEIVED ACK
[2020-10-17 12:23:20.324] [D] [zway] RECEIVED: ( 01 05 01 3B A5 A2 C7 )
[2020-10-17 12:23:20.325] [D] [zway] SENT ACK
[2020-10-17 12:23:20.325] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel1 = 165 (0x000000a5)
[2020-10-17 12:23:20.325] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel2 = 162 (0x000000a2)
[2020-10-17 12:23:20.325] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel3 = 127 (0x0000007f)
[2020-10-17 12:23:20.325] [I] [zway] Job 0x3b (Get background noise level): RSSI Ch#1: -94 dBm, Ch#2: -94 dBm, Ch#3: invalid
[2020-10-17 12:23:20.325] [D] [zway] Job 0x3b (Get background noise level): success
[2020-10-17 12:23:20.326] [I] [zway] Removing job: Get background noise level
[2020-10-17 12:23:22.325] [D] [zway] Job 0x13: deleted from queue

User avatar
PoltoS
Posts: 5887
Joined: 26 Jan 2011 19:36

Re: non-sensor Device Status not updating

Post by PoltoS »

There is special Niffler app that should solve you problem

Post Reply