Problem installing on Rpi with Ubuntu 20.04.01

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
cyb0rg42
Posts: 2
Joined: 13 Nov 2020 15:30

Problem installing on Rpi with Ubuntu 20.04.01

Post by cyb0rg42 »

Hello,

I'm trying to install the Z-Wave server software on my Raspberry Pi4 running Ubuntu Server 20.04.1. The installation ends with:
Your Raspbian distribution is currently not supported by Z-Way
Please contact Z-Wave.Me support for more information
Supported Raspbian distributions are Stretch and Buster

The Z-Wave server software is compiled to a 32-bit platform. I'm running an 64-bit OS.
I got it fixed by enabling the armhf architecture and install the dependencies manually. Yes I known it's very ugly and not recommended.

apt -y install libxml2:armhf libwebsockets15:armhf libarchive-tools:armhf libavahi-compat-libdnssd-dev:armhf libc-ares2:armhf sharutils:armhf

and:
dpkg-deb -x z-way-3.1.1_armhf.deb
dpkg-deb --control z-way-3.1.1_armhf.deb zwave/DEBIAN
sed -i -e 's/websockets8/websockets15/g' zwave/DEBIAN/control
dpkg -b zwave/ z-way-3.1.2_armhf.deb
sudo apt install z-way-3.1.2_armhf.deb
rm -rf zwave

Is there a 64-bit arm64 deb package available. I couldn't find one. And if not is the source code available? I'm happily want to compile to code myself.

Cheers,
Karl

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: Problem installing on Rpi with Ubuntu 20.04.01

Post by PoltoS »

We don't have an arm64 build yet. This is planned for future.

cyb0rg42
Posts: 2
Joined: 13 Nov 2020 15:30

Re: Problem installing on Rpi with Ubuntu 20.04.01

Post by cyb0rg42 »

Hi,

When do you expect to release the 64-bit version? And it is possible to get the source code?

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: Problem installing on Rpi with Ubuntu 20.04.01

Post by PoltoS »

It is scheduled, but no date for now. Please wait until we do it. Meanwhile you can use 32 bits version.

Are you talking about Raspberry OS or Ubuntu for Pi?

Post Reply