Everspring ST814 - Autoreport of sensor data not working

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Everspring ST814 - Autoreport of sensor data not working

Post by SpamNeinDanke »

Hi everyone,

I have set up my little Z-Way network with RaZberry and some devices. Among them is an Eversrping ST814. According to the product manual and the corresponding ZDDX File, the device should be able to Autoreport on the two sensor values (Temp & Humidity) along a configurable time frame (Parameter 6).

Unfortunately I never get back any value from the device. It seems that the setting of some parameters in device configuration does not work (Parameters 3-7).

Does anyone has solved a similar issue or can provide any solution?

Kind regards,

SnD
SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Edit

Post by SpamNeinDanke »

Somehow it seems to send updates but just the UI does not update the sensor data:

...
[2013-03-29 14:44:39.591] RECEIVED: ( 01 0C 00 04 00 06 06 31 05 01 22 00 CF 2F )
[2013-03-29 14:44:39.607] SENT ACK
[2013-03-29 14:44:39.609] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-29 14:44:39.611] SETDATA devices.6.instances.0.commandClasses.49.data.1.deviceScale = 0 (0x00000000)
[2013-03-29 14:44:39.614] SETDATA devices.6.instances.0.commandClasses.49.data.1.scale = 0 (0x00000000)
[2013-03-29 14:44:39.616] SETDATA devices.6.instances.0.commandClasses.49.data.1.val = 20.700001
[2013-03-29 14:44:39.619] SETDATA devices.6.instances.0.commandClasses.49.data.1.scaleString = "°C"
[2013-03-29 14:44:39.621] SETDATA devices.6.instances.0.commandClasses.49.data.1 = Empty
[2013-03-29 14:44:40.230] RECEIVED: ( 01 0B 00 04 00 06 05 31 05 05 01 1B D8 )
[2013-03-29 14:44:40.245] SENT ACK
[2013-03-29 14:44:40.247] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-29 14:44:40.249] SETDATA devices.6.instances.0.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
[2013-03-29 14:44:40.251] SETDATA devices.6.instances.0.commandClasses.49.data.5.scale = 0 (0x00000000)
[2013-03-29 14:44:40.253] SETDATA devices.6.instances.0.commandClasses.49.data.5.val = 27.000000
[2013-03-29 14:44:40.256] SETDATA devices.6.instances.0.commandClasses.49.data.5.scaleString = "%"
[2013-03-29 14:44:40.258] SETDATA devices.6.instances.0.commandClasses.49.data.5 = Empty

...

the same works for an AN158 from Everspring (same SDK-Version as ST814).

Still no clue ...
User avatar
PoltoS
Posts: 6340
Joined: 26 Jan 2011 19:36

Does tab change helps? Or

Post by PoltoS »

Does tab change helps? Or interfce reload? You seems to use the lates version, which should be OK.

May be another reason: there is a bug in Chrome (at loeast in ours) that some values aer not refreshed. A mouse move over the field helps to update the value.
SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Does not help

Post by SpamNeinDanke »

Hi PoltoS,

tab change or refresh of web page does not help. I am using Firefox 19.0.2 though.
I still suspect something different. Manually updating the sensors (one at a time because of device misbehavior) the values shown under sensors update as soon as the device wakes up.
Could it be that Z-Way does not correctly interpret / assign the "pushed" values?
User avatar
PoltoS
Posts: 6340
Joined: 26 Jan 2011 19:36

Solicited and unsolicited (

Post by PoltoS »

Solicited and unsolicited ("pushed") events are exactly same for Z-Way (and in Z-Wave in principle).

If UI reload does not help, means Z-Way really have different updates for both cases. Can you give use logs for the solicited and unslicited cases? As I got, first updates the UI, while the second does not? Let's compare logs.
SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Log data

Post by SpamNeinDanke »

Here are the log snippets:

1) Manual update (requesting update via Demo-UI update button, works):

[2013-03-30 10:09:19.842] Adding job: MultiChannel encapsulation
[2013-03-30 10:09:51.900] RECEIVED: ( 01 08 00 04 00 06 02 84 07 74 )
[2013-03-30 10:09:51.912] SENT ACK
[2013-03-30 10:09:51.914] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:09:51.916] Node 6:0 CC Wakeup: Wakeup notification
[2013-03-30 10:09:51.918] SETDATA devices.6.instances.0.commandClasses.132.data.lastWakeup = 1364634591 (0x5156abdf)
[2013-03-30 10:09:51.919] SETDATA devices.6.data.isAwake = True
[2013-03-30 10:09:51.922] Running wakeup handler for node 6
[2013-03-30 10:09:51.924] SETDATA devices.6.instances.0.commandClasses.132.data.lastSleep = 1364634591 (0x5156abdf)
[2013-03-30 10:09:51.926] Node 6:0 CC Wakeup: Send node to sleep
[2013-03-30 10:09:51.928] Adding job: Wakeup Sleep
[2013-03-30 10:09:51.941] SENDING (cb 0xf0): ( 01 0D 00 13 06 06 60 0D 01 02 31 04 05 F0 4F )
[2013-03-30 10:09:51.968] RECEIVED ACK
[2013-03-30 10:09:51.980] RECEIVED: ( 01 04 01 13 01 E8 )
[2013-03-30 10:09:51.989] SENT ACK
[2013-03-30 10:09:51.991] Delivered to Z-Wave stack
[2013-03-30 10:09:52.003] RECEIVED: ( 01 05 00 13 F0 00 19 )
[2013-03-30 10:09:52.012] SENT ACK
[2013-03-30 10:09:52.013] Job 0x13 (MultiChannel encapsulation): Delivered
[2013-03-30 10:09:52.014] SendData Response with callback 0xf0 received: received by recipient
[2013-03-30 10:09:52.015] SETDATA devices.6.data.lastSend = 5067182 (0x004d51ae)
[2013-03-30 10:09:52.017] Job 0x13 (MultiChannel encapsulation): success
[2013-03-30 10:09:52.018] Removing job: MultiChannel encapsulation
[2013-03-30 10:09:52.087] SENDING (cb 0xf1): ( 01 09 00 13 06 02 84 08 05 F1 99 )
[2013-03-30 10:09:52.111] RECEIVED ACK
[2013-03-30 10:09:52.123] RECEIVED: ( 01 04 01 13 01 E8 )
[2013-03-30 10:09:52.132] SENT ACK
[2013-03-30 10:09:52.134] Delivered to Z-Wave stack
[2013-03-30 10:09:52.146] RECEIVED: ( 01 05 00 13 F1 00 18 )
[2013-03-30 10:09:52.155] SENT ACK
[2013-03-30 10:09:52.157] Job 0x13 (Wakeup Sleep): Delivered
[2013-03-30 10:09:52.158] SendData Response with callback 0xf1 received: received by recipient
[2013-03-30 10:09:52.160] SETDATA devices.6.data.lastSend = 5067191 (0x004d51b7)
[2013-03-30 10:09:52.162] Job 0x13 (Wakeup Sleep): success
[2013-03-30 10:09:52.164] SETDATA devices.6.data.isAwake = False
[2013-03-30 10:09:52.165] Sending the queue for node 6 into sleep
[2013-03-30 10:09:52.167] Removing job: Wakeup Sleep
[2013-03-30 10:09:52.707] RECEIVED: ( 01 0F 00 04 00 06 09 60 0D 02 01 31 05 05 01 29 8C )
[2013-03-30 10:09:52.726] SENT ACK
[2013-03-30 10:09:52.728] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:09:52.729] SETDATA devices.6.instances.2.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
[2013-03-30 10:09:52.731] SETDATA devices.6.instances.2.commandClasses.49.data.5.scale = 0 (0x00000000)
[2013-03-30 10:09:52.733] SETDATA devices.6.instances.2.commandClasses.49.data.5.val = 41.000000
[2013-03-30 10:09:52.736] SETDATA devices.6.instances.2.commandClasses.49.data.5.scaleString = "%"
[2013-03-30 10:09:52.738] SETDATA devices.6.instances.2.commandClasses.49.data.5 = Empty

SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Log data #2

Post by SpamNeinDanke »

Log snippet #2 (containing auto-update for sensors of AN814 = devices.6, not working):

[2013-03-30 10:13:19.889] RECEIVED: ( 01 0C 00 04 00 06 06 31 05 01 22 00 C3 23 )
[2013-03-30 10:13:19.904] SENT ACK
[2013-03-30 10:13:19.906] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:13:19.908] SETDATA devices.6.instances.0.commandClasses.49.data.1.deviceScale = 0 (0x00000000)
[2013-03-30 10:13:19.911] SETDATA devices.6.instances.0.commandClasses.49.data.1.scale = 0 (0x00000000)
[2013-03-30 10:13:19.913] SETDATA devices.6.instances.0.commandClasses.49.data.1.val = 19.500000
[2013-03-30 10:13:19.917] SETDATA devices.6.instances.0.commandClasses.49.data.1.scaleString = "°C"
[2013-03-30 10:13:19.918] SETDATA devices.6.instances.0.commandClasses.49.data.1 = Empty
[2013-03-30 10:13:20.516] RECEIVED: ( 01 0B 00 04 00 06 05 31 05 05 01 29 EA )
[2013-03-30 10:13:20.530] SENT ACK
[2013-03-30 10:13:20.531] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:13:20.533] SETDATA devices.6.instances.0.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
[2013-03-30 10:13:20.536] SETDATA devices.6.instances.0.commandClasses.49.data.5.scale = 0 (0x00000000)
[2013-03-30 10:13:20.538] SETDATA devices.6.instances.0.commandClasses.49.data.5.val = 41.000000
[2013-03-30 10:13:20.541] SETDATA devices.6.instances.0.commandClasses.49.data.5.scaleString = "%"
[2013-03-30 10:13:20.542] SETDATA devices.6.instances.0.commandClasses.49.data.5 = Empty
[2013-03-30 10:13:25.950] RECEIVED: ( 01 0E 00 04 00 02 08 32 02 21 12 00 00 00 00 FC )
[2013-03-30 10:13:25.965] SENT ACK
[2013-03-30 10:13:25.967] SETDATA devices.2.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:13:25.968] SETDATA devices.2.instances.0.commandClasses.50.data.2.val = 0.000000
[2013-03-30 10:13:25.970] SETDATA devices.2.instances.0.commandClasses.50.data.2.delta = 0 (0x00000000)
[2013-03-30 10:13:25.972] SETDATA devices.2.instances.0.commandClasses.50.data.2.ratetype = 1 (0x00000001)
[2013-03-30 10:13:25.973] SETDATA devices.2.instances.0.commandClasses.50.data.2 = Empty
[2013-03-30 10:13:28.814] RECEIVED: ( 01 08 00 04 00 06 02 84 07 74 )
[2013-03-30 10:13:28.826] SENT ACK
[2013-03-30 10:13:28.828] SETDATA devices.6.data.lastReceived = 0 (0x00000000)
[2013-03-30 10:13:28.830] Node 6:0 CC Wakeup: Wakeup notification
[2013-03-30 10:13:28.832] SETDATA devices.6.instances.0.commandClasses.132.data.lastWakeup = 1364634808 (0x5156acb8)
[2013-03-30 10:13:28.834] SETDATA devices.6.data.isAwake = True
[2013-03-30 10:13:28.836] Running wakeup handler for node 6
[2013-03-30 10:13:28.838] SETDATA devices.6.instances.0.commandClasses.132.data.lastSleep = 1364634808 (0x5156acb8)
[2013-03-30 10:13:28.841] Node 6:0 CC Wakeup: Send node to sleep
[2013-03-30 10:13:28.843] Adding job: Wakeup Sleep
[2013-03-30 10:13:28.856] SENDING (cb 0xf6): ( 01 09 00 13 06 02 84 08 05 F6 9E )
[2013-03-30 10:13:28.878] RECEIVED ACK
[2013-03-30 10:13:28.890] RECEIVED: ( 01 04 01 13 01 E8 )
[2013-03-30 10:13:28.897] SENT ACK
[2013-03-30 10:13:28.899] Delivered to Z-Wave stack
[2013-03-30 10:13:28.911] RECEIVED: ( 01 05 00 13 F6 00 1F )
[2013-03-30 10:13:28.918] SENT ACK
[2013-03-30 10:13:28.920] Job 0x13 (Wakeup Sleep): Delivered
[2013-03-30 10:13:28.921] SendData Response with callback 0xf6 received: received by recipient
[2013-03-30 10:13:28.923] SETDATA devices.6.data.lastSend = 5086405 (0x004d9cc5)
[2013-03-30 10:13:28.926] Job 0x13 (Wakeup Sleep): success
[2013-03-30 10:13:28.927] SETDATA devices.6.data.isAwake = False
[2013-03-30 10:13:28.929] Sending the queue for node 6 into sleep
[2013-03-30 10:13:28.931] Removing job: Wakeup Sleep

In the snippet there is also an auto-update of device.2, which is a Everspring AN158. This update gets reflected in the UI (without reloading) btw. So auto updates are processed in general but not for the AN-184. Could this be related to the two sensor values?

Thanks for all your help, PoltoS!

Cheers,
SnD
SpamNeinDanke
Posts: 21
Joined: 26 Mar 2013 21:34

Additional remarks

Post by SpamNeinDanke »

In addition to the logs above I want to add the following observations:

- In device configuration for that device #6 beneath the Parameter section, all the parameters are shown but:

- for two of them there seems to be a bug in the ZDDXML file as they show two sliders and value text fields. they are "Temperature Trigger-On Value" and "Temperature Trigger-Off Value" (param #2 & #3).

- for Parameters #2-7 the Updated time stamp never changes (and is displayed red). For parameters #1 & #8 the Updated time stamp is displayed correctly as of the latest wakeup / discovery time (diplayed black).

Can this be related to the bug in the ZDDXML file?
User avatar
PoltoS
Posts: 6340
Joined: 26 Jan 2011 19:36

The difference is due to

Post by PoltoS »

The difference is due to wrong specific impelemntation of updates: they come not from channels, while both SensorMutilevel are in channels. So, once you update them manually, the correct packet is sent back (since the request is correct). But on autoupdate it is not.There can be a UI fix for this, but it is not elegant. A better way is to do a JS fix:trap the value change with JS bind, check the sensorType value and explicitelly update the value on a channel.Like this:zway.devices[X].SensorMultilevel.data[1].bind(function() {
zway.devices[X].instances[1].SensorMultilevel.data[1].val = this.val;
zway.devices[X].instances[1].SensorMultilevel.data[1] = null; // just kick updateTime
});
zway.devices[X].SensorMultilevel.data[5].bind(function() {
zway.devices[X].instances[2].SensorMultilevel.data[5].val = this.val;
zway.devices[X].instances[2].SensorMultilevel.data[5] = null; // just kick updateTime
});
Allen912
Posts: 9
Joined: 02 Oct 2013 20:25

Problems with the same device

Post by Allen912 »

Hi, I've got problem with Z-Wave.me (on raspberry Pi) and this ST814. After inclusion, it didn't get any informations... : "Interview is not complete yet. You probably have to wake up the device"
Finally, I got "interview failed after several attempts"...
Even if i wake it up, it don't work.

I gotincluded another switch module of everspring (AB157) without any problem...

Rpi restarted, still the same problem..

If anyone can help me.... Here are the details of the device :

Device description
Node Id: 2
Name: Device 2
Zone: Not placed in a zone
Custom device type:
Brand: Everspring
Device type: Routing Multilevel Sensor
Product: ST814
Description: Temperature/Humidity Sensor
To (re-)include: Tripple press C/F button
To wake up: Stays awake for 10 min. after inclusion, tripple click on C/F
Documents:
Interview stage: Interview is not complete yet. You probably have to wake up the device
+ +++ .++.++ . .
Device state: Device is currently sleeping
Number of packets to be sent: Per-device job counter is disabled
Application version: 1.6
SDK version: 5.02 pl2
Associations
Battery Status and Sensor Report (Maximum allowed nodes: 1, updated 19:02)
RaZberry
Sensor Triggered (Maximum allowed nodes: 3, updated 19:02)
RaZberry
Configurations
1. Basic Level Set : Disable Use value
Updated: 19:16
Default value: 99
Set basic set value to be on or off
2. Temperature Trigger ON value : Trigger On on Trigger On on Disable
Updated: 19:16
Default value: 99
Temperature level when a ON command is sent out
3. Temperature Trigger OFF value : Trigger Off on Trigger Off on Disable
Updated: 19:16
Default value: 99
Trigger Temperature level when a OFF command is sent out
4. Humidity Trigger ON value : Trigger On on Disable
Updated: 19:16
Default value: 99
Humidity level when a ON command is sent out
5. Humidity Trigger OFF value : Tigger Off on Disable
Updated: 19:16
Default value: 99
Humidity level when a OFF command is sent out
6. Auto Report Time : Disable Auto report periodically
Updated: 19:16
Default value: 0
Sets the time interval when a sensor report is sent
7. Auto Report Temperature : Disabled Auto report on temp. change
Updated: 19:16
Default value: 0
Sets the temperature change causing a sensor report
8. Auto Report Humidity : Disable Auto report on humidity change
Updated: 19:16
Default value: 0
Sets the humidity change causing a sensor report
Wakeup notifications
Wakeup time, seconds(300)
to Node
Updated: 19:02
Actions with configurations
Configurations are applied only after you send them to the device

The device is battery powered. New configurations would be applied after manual or next scheduled wakeup at 19:21
Post Reply