Fibaro FGMS-001 and setting temperature offset

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
Rklootwijk
Posts: 15
Joined: 05 Jan 2015 21:52

Fibaro FGMS-001 and setting temperature offset

Post by Rklootwijk » 19 Sep 2015 11:13

By default the z-way version 2.1.1 (Razberry) sets the temperature offset (parameter 66) to 64536 which means -100 degrees. When I change this to 0, it is send correctly to the device. However in the UI the value is changed to 64536 immediately again and the next time a configuration update is send, because you changed another parameter, the device is using an offset of -100 degrees again.

Am I doing something wrong here, or is this a bug?

Cornelius
Posts: 6
Joined: 20 Apr 2016 11:37

Re: Fibaro FGMS-001 and setting temperature offset

Post by Cornelius » 23 Apr 2016 08:44

I got exactly the same problem, but with v.2.2.2!

Is there any human-editable files that contain these default values i can change?

It's really annoying, having to remember to always set the temp. offset to zero each time you change anything else there. (Or having to wait for the next wakeup if you forgot...)

User avatar
PoltoS
Posts: 5112
Joined: 26 Jan 2011 19:36

Re: Fibaro FGMS-001 and setting temperature offset

Post by PoltoS » 04 Aug 2016 21:00

You can edit ZDDX file selected for this device. You can check it in /ZWaveAPI/Run/devices[XX].data, search for ZDDXMLFile

Cornelius
Posts: 6
Joined: 20 Apr 2016 11:37

Re: Fibaro FGMS-001 and setting temperature offset

Post by Cornelius » 07 Aug 2016 17:55

I can't find the path you specified, but i did find a ZDDX folder in "/opt/z-way-server"...

Running a 'grep "FGMS" *' in the ZDDX folder, i get:

Code: Select all

540-010f-0800-1001-03-03-43-02-04.xml:                <productCode>FIB_FGMS-001 V2.4</productCode>
601-010f-0800-4001-03-03-43-02-06.xml:                <productCode>FIB_FGMS-001 V2.6</productCode>
673-010f-0801-1001-03-04-05-03-02.xml:            <productName>FGMS-001</productName>
785-010f-0801-2001-03-04-05-03-02.xml:            <productName>FGMS-001</productName>
ZDDX.indx:271   2049    8193    4       7       1       3       2       4       5       Fibaro  FGMS-001        http://www.pepper1.net/zwavedb/uploads/resources/248d1766bc27884062b4d6ab971c9163cc2db8ec.png     785-010f-0801-2001-03-04-05-03-02.xml
ZDDX.indx:271   2049    4097    4       7       1       3       2       4       5       Fibaro  FGMS-001        http://www.pepper1.net/zwavedb/uploads/resources/ace083b91b53dd1552a885fdb9ccc69946c26c8b.jpg     673-010f-0801-1001-03-04-05-03-02.xml
ZDDX.indxml:    <DeviceDescription appSubVersion="2" appVersion="3" basicClass="4" brandName="Fibaro" deviceImageURL="http://www.pepper1.net/zwavedb/uploads/resources/248d1766bc27884062b4d6ab971c9163cc2db8ec.png" filePath="785-010f-0801-2001-03-04-05-03-02.xml" genericClass="7" manufacturerId="271" productId="8193" productName="FGMS-001" productType="2049" protoSubVersion="5" protoVersion="4" specificClass="1"/>
ZDDX.indxml:    <DeviceDescription appSubVersion="2" appVersion="3" basicClass="4" brandName="Fibaro" deviceImageURL="http://www.pepper1.net/zwavedb/uploads/resources/ace083b91b53dd1552a885fdb9ccc69946c26c8b.jpg" filePath="673-010f-0801-1001-03-04-05-03-02.xml" genericClass="7" manufacturerId="271" productId="4097" productName="FGMS-001" productType="2049" protoSubVersion="5" protoVersion="4" specificClass="1"/>
The xml files for my version of FGMS-001 would be either the one starting with '673' or '785'; Neither one of them have an odd default value for the temp. offset...

Code: Select all

        <configParam number="66" type="range" size="2" default="0000">
            <name>
                <lang xml:lang="en">TEMPERATURE OFFSET</lang>
              </name>
                  <description>
                <lang xml:lang="en">
The value to be added to the actual temperature, measured by the sensor (temperature compensation).
</lang>
              </description>

                  <value from="fc18" to="03e8">
                <description>
                    <lang xml:lang="en">
Define the value of added temperature. Available settings: -1000 - 1000 (-100°C – 100°C)
</lang>
                  </description>
              </value>
                </configParam>
Am i at the wrong place? :)

User avatar
PoltoS
Posts: 5112
Joined: 26 Jan 2011 19:36

Re: Fibaro FGMS-001 and setting temperature offset

Post by PoltoS » 08 Aug 2016 12:27

Code: Select all

<value from="fc18" to="03e8">...</value>
This is odd. from > to. Should be splitted in two:

Code: Select all

<value from="0000" to="03e8">...</value>
<value from="fc18" to="ffff">...</value>

Post Reply