Page 1 of 1

Can't trigger Aeotec Alarm 6

Posted: 25 Aug 2019 14:34
by Xusqui
Hello, neighbours and friends...

I have been using a Raspberry pi 3 + Razberry for a while. Recently I updated to 3.0.0, and as it went wrong, I completely uninstalled it and reinstalled from scratch and everything went fine that time.

In my config a Only had a Door Sensor (Aeotec) and a fire alarm (Fibaro), and both work great (I guess Fibaro sensor works great, although it was never triggered).

Recently I bought the Aeotec Alarm 6, and I included in my z-wave network like a charm, without any problems (S2 included).

Now I am unable to create a recipe to make the alarm sound when the door is open.

I see all the accessories in the "elements" view, but when I create a IF/THEN Recipe I can use the door sensor open in the IF part, but only can Send Notification by e-mail in the THEN part. The alarm accesorio is shown in the IF part as binary sensors which they are not...

Any clue on this?

Thanks in advance

Re: Can't trigger Aeotec Alarm 6

Posted: 31 Aug 2019 01:37
by PoltoS
This is a known problem. We will fix it soon. You can workaround it by executing /JS/Run/controller.devices.get("VDEV").set("metrics:probeType", "alarm") for all devices that looks like alarms. VDEV should substitute the device ID that appers when you put your mouse on the gear on the device widget.

We will fix it in v3.0.1

Re: Can't trigger Aeotec Alarm 6

Posted: 22 Sep 2019 12:37
by Xusqui
Thank you very much!!

Sorry I missed your answer as I finished my holidays :(

I've tried,jor URL, but didn't work, I get an error:
TypeError: Cannot read property 'set' of null
This is what I entered in the address box:

Code: Select all"16").set("metrics:probeType","alarm")
As I guess my device ID is 16:


But I also tried with 16.0

Maybe I'm doing something wrong...

Re: Can't trigger Aeotec Alarm 6

Posted: 22 Sep 2019 13:21
by Xusqui
Ok... My fault with the VDEV... It was not something like 16 but something like "ZWayVDev_zway_16-5-113-8-10-A"

Now I get a error-free answer:

Code: Select all

	"creationTime": 1566986272,
	"creatorId": 1,
	"customIcons": {},
	"deviceType": "sensorBinary",
	"h": -1684480381,
	"hasHistory": false,
	"id": "ZWayVDev_zway_16-5-113-8-10-A",
	"location": 0,
	"locationName": "globalRoom",
	"metrics": {
		"icon": "alarm",
		"level": "off",
		"title": "Power Management Alarm (16.5)",
		"isFailed": false,
		"probeType": "alarm"
	"nodeId": 16,
	"order": {
		"rooms": 0,
		"elements": 0,
		"dashboard": 0
	"permanently_hidden": false,
	"probeType": "alarm_power",
	"tags": [],
	"visibility": true,
	"updateTime": 1569147474
will make some tests now!

Thank you!

Re: Can't trigger Aeotec Alarm 6

Posted: 22 Sep 2019 20:42
by Xusqui
I keep on trying but I see no way to trigger the alarm.

Actually I updated to 3.0.1 with the Raspbian package from official page: and still the same issue.

I think the error is in

Code: Select all

"deviceType": "sensorBinary",
As it's not a sensorBinary, but I've tried switchBinary and some others with no luck...

Any ideas?

Re: Can't trigger Aeotec Alarm 6

Posted: 23 Sep 2019 22:54
by Xusqui

Re: Can't trigger Aeotec Alarm 6

Posted: 30 Oct 2019 14:59
by shreyaraina
Great Post :)