Couldn't open serial port in Zwave programmer by

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
Posts: 1
Joined: 06 Sep 2019 17:49

Couldn't open serial port in Zwave programmer by

Post by dipesh.sharma »


I got programmer with which i received programming manual with steps for configuring for setup.

As per the manual i create ~/fw500 directory in which i stored the binaries(.hex) and created firmwares.csv with provided information about product name, cs, module name, vid, pid, eeprom etc.

After that i tried to flash the device but it shown me error with couldn't open /dev/AMCO.

Error 0 Could not open serial port /dev/ACM0: could not open port /dev/ACM0: [Errno 2] No
such file or directory: '/dev/ACM0'

I tried to update programmer.json with example and added instance which provide the communication port detected in my system, but still i faced the same error which mention port can't be opened.

Also the manual has upgraded tool version of zme programmer than one i am using. Does this effect the serial port open issue??

THanks in advance.

Can someone guide me in this issue.

For reference i attach the screenshot of error which i am facing.


Post Reply