MxInfo - Page Not Found

Tips, Tricks and Scripts to enhance your home automation and workaround known device bugs, limitations and incompatibilities
Post Reply
micky1500
Posts: 250
Joined: 07 Feb 2016 16:29

MxInfo - Page Not Found

Post by micky1500 »

Hello,
@piet66

Thanks for sharing your MxInfo Tools, I like it.
Can I report an issue !


MxInfo has not worked for a while. (Currently on 3.2.3)
It says page not found.
http://IP:8083/smarthome/user/MxInfo
I have uninstalled it, Restarted, Re-Installed, Restarted.
Still not working.


'set_clear_link.bash.log' was saying No such file or directory for :-
ln -s /opt/z-way-server/automation/userModules/MxInfo/user/MxInfo /opt/z-way-server/htdocs/smarthome/user/MxInfo

I changed 'set_clear_link.bash' to add the folder 'dist'
SMARTHOMEDIR=$ROOT/htdocs/smarthome/dist/user
Restarted and re-applied the "Installation - Create Link"
Restarted again.

Now works, but with a different url.
http://IP:8083/smarthome/dist/user/MxInfo

Might have worked if I created an empty folder \opt\z-way-server\htdocs\smarthome\user
But I did not try that as it's now working and I don't want to break it.

Thankyou

Micky
Raspi 4 - (Buster - 32 Bit) Zwave Version 3.2.3 Raz 7 Pro, Serial API Version: 07.28
piet66
Posts: 173
Joined: 04 Feb 2017 17:00

Re: MxInfo - Page Not Found

Post by piet66 »

Hi,
seems that the folder /opt/z-way-server/htdocs/smarthome/user/ was missing, so that the link couldn't work.

Normally this folder does exist. Maybe the update to 3.2.3 hast destroyed it? An update normally preserves this folder with its contents.

And where did the dist subfolder come from*? That's new.

If they have changed the folder tree, I must alter the script.
Raspberry Pi 3 Model B Rev 1.2
Raspbian GNU/Linux 10 (buster)
RaZberry by Z-Wave.Me ZW0500 6.82.01 05.39/35498 1024/2
Z-Way version v3.2.3 from 2022-04-06 04:56:23 +0300
micky1500
Posts: 250
Joined: 07 Feb 2016 16:29

Re: MxInfo - Page Not Found

Post by micky1500 »

Hi,
I did not add any folders, I found the dist folder because it had the user folder in it.

My previous versions of MxInfo were manually installed (Extract the contents of the zip file to z-way-server/htdocs/smarthome/user/.)
This is the first time I have used the Installation link.

Maybe PoltoS will comment !
Raspi 4 - (Buster - 32 Bit) Zwave Version 3.2.3 Raz 7 Pro, Serial API Version: 07.28
User avatar
PoltoS
Posts: 6987
Joined: 26 Jan 2011 19:36

Re: MxInfo - Page Not Found

Post by PoltoS »

No, nothing has changed around this folder. Can you confirm that the folder is moved on upgrade to the new Z-Way?
piet66
Posts: 173
Joined: 04 Feb 2017 17:00

Re: MxInfo - Page Not Found

Post by piet66 »

Just upgraded to Version 3.2.3 via apt-get upgrade:

Folder /opt/z-way-server/htdocs/smarthome/user/ is still existing with its contents,
no subfolder 'dist/user'.

Only the contents of .syscommands is deleted again.
Raspberry Pi 3 Model B Rev 1.2
Raspbian GNU/Linux 10 (buster)
RaZberry by Z-Wave.Me ZW0500 6.82.01 05.39/35498 1024/2
Z-Way version v3.2.3 from 2022-04-06 04:56:23 +0300
lanbrown
Posts: 100
Joined: 01 Jun 2021 08:06

Re: MxInfo - Page Not Found

Post by lanbrown »

You should be able to just re-run the installer. If there is already a configuration I have found the installer does not overwrite the config, just installs/upgrades Z-Way.

Code: Select all

wget -qO - https://storage.z-wave.me/RaspbianInstall | sudo bash
micky1500
Posts: 250
Joined: 07 Feb 2016 16:29

Re: MxInfo - Page Not Found

Post by micky1500 »

I'm 100% sure I did not remove or create any folders !

My update history !
v3.2.1 installed 17/09/2021 mosquito not found error
v3.2.1 installed 19/09/2021 Reinstalled with libmosquito fix
v3.2.2 installed 30/11/2021 Should fix Then-Else issue
v3.2.2 added Vera 05/03/2022 Associations all went wrong, running ver7 firmware with issues
3.2.2-lws16 installed 25/03/2022 3.2.3 beta for latest v7 firmware
v3.2.3 installed 02/04/2022

Should I create a new folder /opt/z-way-server/htdocs/smarthome/user/ ?
And delete the "dist" folder ?
Raspi 4 - (Buster - 32 Bit) Zwave Version 3.2.3 Raz 7 Pro, Serial API Version: 07.28
piet66
Posts: 173
Joined: 04 Feb 2017 17:00

Re: MxInfo - Page Not Found

Post by piet66 »

Should I create a new folder /opt/z-way-server/htdocs/smarthome/user/ ?
And delete the "dist" folder ?
Doesn't matter if the link is created in user/ or in dist/user. If you have no problem, you can stay with the current state.

Next version of MxInfo will create folder user, if it doesn't exist. This solves the problem, no matter where it comes from.
Raspberry Pi 3 Model B Rev 1.2
Raspbian GNU/Linux 10 (buster)
RaZberry by Z-Wave.Me ZW0500 6.82.01 05.39/35498 1024/2
Z-Way version v3.2.3 from 2022-04-06 04:56:23 +0300
micky1500
Posts: 250
Joined: 07 Feb 2016 16:29

Re: MxInfo - Page Not Found

Post by micky1500 »

Nice one.

Thanks
Raspi 4 - (Buster - 32 Bit) Zwave Version 3.2.3 Raz 7 Pro, Serial API Version: 07.28
Post Reply