MulitChannel reports with multi channel association

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
A.Harrenberg
Posts: 201
Joined: 05 Sep 2016 22:27

MulitChannel reports with multi channel association

Post by A.Harrenberg »

Hi PoltoS,

I've noticed a "strange" behavior with the mulitchannel reports in multichannel association. I am not quite sure if I set up the association not properly or if it is coming from the Z-Uno.

I have extended my sketch (the one you were looking for the wrong line numbers) to send also the report for channel 1 (switch_multilevel), deleted the association from lifeline and set up the multi channel association for group 1.

Channel 1 is a switch_multilevel, channel 2 is a sensor_mulitlevel reporting temperature and channel 3 is a sensor_multilevel reporting humidity.

I receive now 5 reports, each channel is send from the endpoint to the group, that is what I have expected, but I also receive 2 more reports for the switch and the temperature that are addressed from endpoint 0. That leads to my "dimmer" reporting a temperature...

Code: Select all

07600d 01 01 260300
07600d 00 01 260300
0a600d 02 01 3105012200e6
0a600d 00 01 3105012200e6
0a600d 03 01 3105052201cc
This is my first device supporting multichannel/multichannel association that I am testing, so I am not very familiar with the details of this command class, but there seems to be something strange here.

Main question is why are there messages addressed from endpoint 0, second question if this is intended would be why are they only send for the first two channels and not also for the third channel.

In the meantime I will have a closer look at the specification of the class to validate that I set up the multichannel association correctly. If it helps, this is reported as an answer to an "Multi_Channel_Association_Get" command:

Code: Select all

ARG:088e03010500000101
For me that looks good...

Regards,
Andreas.
fhem.de - ZWave development support

User avatar
PoltoS
Posts: 5626
Joined: 26 Jan 2011 19:36

Re: MulitChannel reports with multi channel association

Post by PoltoS »

This is because some channels are mapped to root device and sending update we also update the root device.

This fits the standard. Your hime madr controller should handle this. I still suggest you not to invent the wheel, but take Z-Way and connect your logic to our advanced engine that makes all the parsing for you.

A.Harrenberg
Posts: 201
Joined: 05 Sep 2016 22:27

Re: MulitChannel reports with multi channel association

Post by A.Harrenberg »

Hi PoltoS,

I am not trying to invent something here, I am only trying to use the Z-Uno as it is. You explained that each channel has only one value and that therefore only one value will be reported for each device and I just tried to set up the multi channel associations for it.

The mix of "some channels are mapped to the root device" and the rule "one value per channel" just create some strange side-effects here for me.

What is the logic behind the channels mapped to the root device? Why are only the first two mapped to the root?

I am just a little confused about the fact that the rule you explained to me seems to have some exceptions and the rules for this exception are not clear to me. If all the three channels were reported to the root device then I would be be able to have all the different readings in the root device by modifying the behavior for these messages as this was my very first intention to have all readings in one place.

So is there a chance of having ALL the channel reports also send to the root device?

Regards,
Andreas.
fhem.de - ZWave development support

User avatar
PoltoS
Posts: 5626
Joined: 26 Jan 2011 19:36

Re: MulitChannel reports with multi channel association

Post by PoltoS »

This is a requirement by Z-Wave Plus. First channel MUST be mapped to root device. We map first channel if each type to maximize the compatibility with old controllers.

Please read this: http://z-uno.z-wave.me/Reference/Z-Wave/ section Channels.

A.Harrenberg
Posts: 201
Joined: 05 Sep 2016 22:27

Re: MulitChannel reports with multi channel association

Post by A.Harrenberg »

Hi PoltoS,

thnx for the information, I certainly overlook that piece of text... So that explains the logic behind it.

Might I still have a request? :-)

Will it be possible to extend the logic not to only allow one channel of each type mapped to the root if e.g. the "sensor_type" is different?

So in my case the two Sensor_Multilevel use different sensor_types (TYPE_TEMPERATURE and TYPE_RELATIVE_HUMIDITY) and they could report both to the root without problems.

The other "problem" that the temperature from channel 2 is reportend in channel 1 seems to be within my automation system as there is a workaround for some non-compliant sensor implemented that is triggered in this case where it should not be active.

Best regards,
Andreas.
fhem.de - ZWave development support

User avatar
PoltoS
Posts: 5626
Joined: 26 Jan 2011 19:36

Re: MulitChannel reports with multi channel association

Post by PoltoS »

We will think about it. Same a out one single channel - we will change Z-Uno in future to supress single channel.

Post Reply