Page 1 of 2

Z-Uno and Zipato

Posted: 24 Oct 2017 15:29
by sega66
I downloaded the sketch from the example "OneWire temperature sensor DS18B20"
http://z-uno.z-wave.me/examples/multipl ... e-sensors/
The controller Zipato shows the temperature from the sensors, but does not allow the use of the readings in the rules.
Writes - "no attributes".
Arduino IDE 1.6.5 Z-Uno v 2.1.0

Re: Z-Uno and Zipato

Posted: 24 Oct 2017 22:13
by pjpankhurst
I have noticed the same problem with the Hauppauge controller (which currently runs an old variant of the Zipato firmware).
That's with the very latest 1.85 IDE and 2.1.1 Z-Uno

Is your Zipato controller running the very latest firmware?

Re: Z-Uno and Zipato

Posted: 26 Oct 2017 09:05
by sega66
I have not tried Zipato with the latest version Z-Uno.

Re: Z-Uno and Zipato

Posted: 28 Oct 2017 18:43
by sega66
Latest 1.85 IDE and 2.1.1 Z-Uno.
The controller Zipato shows the temperature from the sensor, but does not allow the use of the readings in the rules.
Writes - "no attributes".
Why is this? Where can I go to support Zipato or blame Z-Uno ?
Maybe I'm doing something wrong ?

Code: Select all

 
 #include <ZUNO_DS18B20.h>
#define PIN_OW 9     //
OneWire ow(PIN_OW);  //
DS18B20Sensor sen18b20(&ow);//
#define NUMBER_OF_SENSORS 1
#define ADDR_SIZE 8

ZUNO_SETUP_SLEEPING_MODE(ZUNO_SLEEPING_MODE_ALWAYS_AWAKE);

byte  sensor_addresses[NUMBER_OF_SENSORS * ADDR_SIZE] =
{
  0x28, 0xEE, 0xC4, 0x3A, 0x2E, 0x16, 0x01, 0x32,
};

int temp[NUMBER_OF_SENSORS];

ZUNO_SETUP_CHANNELS(
  ZUNO_SENSOR_MULTILEVEL(ZUNO_SENSOR_MULTILEVEL_TYPE_TEMPERATURE, SENSOR_MULTILEVEL_SCALE_CELSIUS, SENSOR_MULTILEVEL_SIZE_TWO_BYTES, SENSOR_MULTILEVEL_PRECISION_TWO_DECIMALS, getterTemp0)
);
unsigned long previousMillis = 0;
const long interval = 60000;

void setup() {
}
void loop()
{
  unsigned long currentMillis = millis();
  if (currentMillis - previousMillis >= interval) { //
    previousMillis = currentMillis;
    byte address[ADDR_SIZE];
    // use byte instead of int to reduce code size
    for (byte i = 0; i < NUMBER_OF_SENSORS; i++)
    {
      for (byte j = 0; j < ADDR_SIZE; j++)
      {
        address[j] = sensor_addresses[i * ADDR_SIZE + j];
      }
      temp[i] = sen18b20.getTempC100(address);
      delay (40);
      zunoSendReport(1 + i);
    }
  }
}

word getterTemp0()
{
  return temp[0];
}
 [/ code]

Re: Z-Uno and Zipato

Posted: 31 Oct 2017 10:40
by sega66
Can someone check this code on a controller other than zipato?
I can add it Z-Uno to the Zipabox without problems and also get values. It shows and updates just fine in the app.
However, I am unable to create any rules with the unit as it just says "no attributes" in the dropdown
The answer Zipato:
This device is not full supported by Zipato. When you add it you receive generic descriptor for it and you can use of its functionalities.
We don't have full support for this device.

Re: Z-Uno and Zipato

Posted: 01 Nov 2017 00:19
by PoltoS
we can chek it on Friday on RaZberry. But I would suggest Zipato to contact us. We tried to contact them directly, but as non-Zipato users we got a negative naswer on our support ticket.

Re: Z-Uno and Zipato

Posted: 01 Nov 2017 09:22
by sega66
Thank you!
I opened a ticket to Zipato and put in a copy a response from you (Serguei G. Poltorak
ps) about the readiness to actively cooperate. Zipato responded like this:
I apologize for late reply. Zipato doesn't have full support for Z-Uno device.
When you include Z-Uno device you will receive generic descriptor which will show just some of the basic device functionalities.
Unfortunately you device is not fully supported and that is the reason why you don't have attributes.

Best regards,

Vedran Tarodi
zipato

Re: Z-Uno and Zipato

Posted: 03 Nov 2017 14:04
by aivs
Sketch works correct in RaZberry. I can get temperature, sensor type and scale correct.
1.png
1.png (531.23 KiB) Viewed 4492 times
2.png
2.png (172.96 KiB) Viewed 4492 times

Re: Z-Uno and Zipato

Posted: 03 Nov 2017 14:15
by sega66
aivs
Thank you for checking!
This proves that Zipato is to blame, but they do not want to correct their mistakes :(

Re: Z-Uno and Zipato

Posted: 05 Nov 2017 03:03
by pjpankhurst
@sega66 - I wonder if the values can be read from the Zipato REST interface..if they can it may be possible to copy them into a virtual device that can then be used by the zipato rules as a temporary workaround..havent had a chance to test this yet myself