Page 1 of 2

Wakeup not working at all

Posted: 17 Aug 2018 18:05
by stecrz
I thought sleeping works as follows: After calling zunoSendDeviceToSleep the Z-Uno will sleep until INT1 is set to LOW. Unfortunately this does not work. I cannot wakeup the Z-Uno by connecting pin 18 (or any other pin) to GND. The only wakeup possibility is to press the RST button. What's the problem?

Here some sample code. LED will blink once, then only again after reconnecting (USB) or pressing RST button, but not by connecting INT1 to GND... The green LED blinks continously (even when the device seems to be asleep).

Code: Select all


void setup() {

void loop() {
  // blink to show chip is awake:
  digitalWrite(LED_BUILTIN, HIGH);
  digitalWrite(LED_BUILTIN, LOW);

Re: Wakeup not working at all

Posted: 18 Aug 2018 19:46
by PoltoS
May be it is related to ... 99&p=77681

Please try beta 2.1.5

Re: Wakeup not working at all

Posted: 20 Aug 2018 10:27
by stecrz
Thanks for the reply! How can I install v2.1.5 beta? Arduino IDE only shows 2.1.4 (and older versions) in the boardmanager.

EDIT: I had to remove " ... index.json" and instead use " ... index.json".

Tested v 2.1.5 (beta), but this did not solve the problem. Z-Uno will not wake up unless you press the RST button.

EDIT: I tested with other Z-Unos and it seems like the wakeup is possible if the device was not included in a network. But I thought of inlcuding the device into a network (connecting with a controller) and then using the FLiRS mode. But additionally, I wanted to wakeup the Z-Uno by another device when the other device has changed data that should be sent. So the values come via UART and the other device needs to wakeup Z-Uno. Device that were included seem to fall alseep but the green LED continues blinking... :( Must be a software issue?

Re: Wakeup not working at all

Posted: 23 Aug 2018 01:09
by PoltoS
Can you provide us some minimal code? We will check and fix this issue

Re: Wakeup not working at all

Posted: 24 Aug 2018 18:20
by stecrz
zunoSetWUOptions does not work with ZUNO_WUPFLAGS_INT1_HIGH, that seemed to be the problem we had. Use ZUNO_WUPFLAGS_INT1_LOW instead as Z-Uno will wakeup continously when using ZUNO_WUPFLAGS_INT1_HIGH (even if you connect INT1 to GND directly).

Re: Wakeup not working at all

Posted: 25 Aug 2018 10:06
by rishamee

I have an issue with wakeup too. My Z-Uno wakes up, every 4 minutes. But the wakeup interval is set to 3600 (?). When the device wakes up, it executes setup() and loop(), but it does not send a Wake Up Notification.

When I wake it up by pressing the service button 3 times, it sends a NIF to the controller. The controller then sends all the waiting messages in the queue.

I tried 2.1.3, 2.1.4 and 2.1.5, all with the same result.

With 2.1.4 and 2.1.5 I had another issue, the inclusion of the Wakeup command class failed (I use a Raspberry Pi with Razberry as controller), but when I include the Z-Uno first and then upgrade to 2.1.4 or 2.1.5, I have the "not sending the Wake Up Notification"-problem.

Can anybody tell me what to do?

Re: Wakeup not working at all

Posted: 25 Aug 2018 12:35
by steinis
I have the same problem with wake up is failing and Aldo the association failed.

Re: Wakeup not working at all

Posted: 26 Aug 2018 17:52
by PoltoS
The wake up every 4 minutes is by design. The device wakes up to check how many left till your wakeup period and then goes into sleep. Every hour (3600 seconds) it should send the Wake Up Notification. Please check it.

Re: Wakeup not working at all

Posted: 27 Aug 2018 09:17
by rishamee
I checked it. No Wake Up Notification for the Z-Uno in the Zniffer History in the last 24 hours. Checked /var/log/z-way-server.log, no Wakeup notification logmessages there (for the Z-Uno). To be sure I checked the wakeup interval, it is set to 3600.

Re: Wakeup not working at all

Posted: 29 Oct 2018 11:54
by DerLexus
I can confirm this and have the same problem with a sketch using ZUNO_SLEEPING_MODE_SLEEPING and zunoSendDeviceToSleep().

I set the wakeup to 4min... the z-uno wakes and is sending its reports. But it does not receive any waiting configuration messages from the controller. I guess it does not send an wakeup notification. If i press the Service button 3 times it sends a NIF and receives all waiting configuration messages.

Is there any possibility to use the Z-Uno logging (to UART) to confirm a missing wakeup notification?

And another thing: The Service-Button configuration refresh described above only works if i add a short delay (around 500ms) before using zunoSendDeviceToSleep().