How to use multichannel ?

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
Jdouc
Posts: 1
Joined: 04 Feb 2020 09:58

How to use multichannel ?

Post by Jdouc »

Hi everyone,

I’ve spent 2 days in trying to get the zwave multichannel working.

The zuno is attached to an eedomus box. From my understanding, the zwave layer in the zuno is somehow “optimizing” the multichannel configuration, so that the same types of channels are somehow grouped into one channel.

I tried a lot of multichannel inclusion commands with the eedomus, this is for now unsuccessful.
I cannot exclude that the controller itself is not messing the attachment, but the eedomus is intended to manage the zuno with multichannel zwave.

The thing is, my project is to control a Fujitsu a/c, so I definitely need the multichannel feature: on/off, target temperature, room temperature, mode...

Has anyone succeeded in attaching a zuno to an eedomus with multichannel?

Thanks for your support :-)

User avatar
PoltoS
Posts: 5611
Joined: 26 Jan 2011 19:36

Re: How to use multichannel ?

Post by PoltoS »

If eedomus is based on OpenZWave, you should make a template for OpenZWave

C.Scavardo
Posts: 5
Joined: 25 May 2020 20:32

Re: How to use multichannel ?

Post by C.Scavardo »

Hi, I just started playing with Z-Uno, and eedomus.
I can connect 2 leds on the Z-Uno, and turn them ON or OFF.
The LED status is correctly updated in the eedomus.
I used:

Code: Select all

ZUNO_SETUP_CHANNELS(
  ZUNO_SWITCH_BINARY(getterLed1, setterLed1),
  ZUNO_SWITCH_BINARY(getterLed2, setterLed2)
);
Then; I connected a button, INPUT_PULLUP mode:

Code: Select all

ZUNO_SETUP_CHANNELS(
  ZUNO_SENSOR_BINARY(ZUNO_SENSOR_BINARY_TYPE_DOOR_WINDOW,getterButon)
);
That button was correctly handled in eedomus.

So, I added another one button:

Code: Select all

ZUNO_SETUP_CHANNELS(
  ZUNO_SENSOR_BINARY(ZUNO_SENSOR_BINARY_TYPE_DOOR_WINDOW,getterButon1),
  ZUNO_SENSOR_BINARY(ZUNO_SENSOR_BINARY_TYPE_DOOR_WINDOW,getterButon2)
);
And, the behaviour looks broken, from eedomus point of view.
The values are correctly updated in the serial monitor, but, the eedomus does not reflect them.
The eedomus will update the values when it will do the polling, reduced to 30 seconds in that case.
But, looks like the zunoSendReport(pin) does nothing, from the eedomus.
I can notive that getters are corrects, values are corrects... but, eedomus values are incorrects... why... still investigating !

User avatar
PoltoS
Posts: 5611
Joined: 26 Jan 2011 19:36

Re: How to use multichannel ?

Post by PoltoS »

Make sure to set up a multichannel association group #1 with 1:0

C.Scavardo
Posts: 5
Joined: 25 May 2020 20:32

Re: How to use multichannel ?

Post by C.Scavardo »

Hi PoltoS,
Is there a doc to "set up a multi channel association group #1 with 1:0" ?
Z-Uno is new for me, I don't understand.
Thank you.

User avatar
PoltoS
Posts: 5611
Joined: 26 Jan 2011 19:36

Re: How to use multichannel ?

Post by PoltoS »

You need to open Association tab in your Z-Wave controller and set multichannel association in group 1 of Z-Uno to 1:0

C.Scavardo
Posts: 5
Joined: 25 May 2020 20:32

Re: How to use multichannel ?

Post by C.Scavardo »

Thank you PoltoS, I'll try soon ;-)

Post Reply