installation error: "zuno_toolchain is not available for your OS"

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
norbert
Posts: 5
Joined: 28 May 2015 23:22

installation error: "zuno_toolchain is not available for your OS"

Post by norbert »

Hi there,

I just got the new Z-Uno and followed the instruction under https://z-uno.z-wave.me/install to set up the Arduino IDE (latest v1.8.13).

But I failed in step 5 : "Go to Tools → Board → Boards manager. Scroll down, you should see a package "Z-Uno by Z-WAVE>ME". Install it"

When I click on install button I get the following error:
"Werkzeug zuno_toolchain ist für Ihr Betriebssysten nicht verfügbar", in english something like: "Tool zuno_toolchain is not available for your OS".

The full output in the IDE window is this:

Werkzeug zuno_toolchain ist für Ihr Betriebssystem nicht verfügbar.
java.lang.RuntimeException: java.lang.Exception: Werkzeug zuno_toolchain ist für Ihr Betriebssystem nicht verfügbar.
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:175)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Werkzeug zuno_toolchain ist für Ihr Betriebssystem nicht verfügbar.
at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:89)
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172)
... 1 more


I am using Windows 10 (1909) 64-bit OS.

I have reinstalled Java (version 8 update 251), because it appears, that java code is executed here.
Also done everything a administrator.

I searched the forum for this message, but did not find anything helpful.
Is there anyone out there, who can tell what I am doing wrong or what is missing on my PC?

Thanks a lot!
Norbert

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: installation error: "zuno_toolchain is not available for your OS"

Post by PoltoS »

Please use Arduino IDE 1.8.12. The new 1.8.13 will be supported soon

norbert
Posts: 5
Joined: 28 May 2015 23:22

Re: installation error: "zuno_toolchain is not available for your OS"

Post by norbert »

Thank you very much for the quick reply. IDE 1.8.12 did the job and I can retrieve Board Information!

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: installation error: "zuno_toolchain is not available for your OS"

Post by PoltoS »

We have just release 2.1.6 - should now work with 1.8.13 too
https://forum.z-wave.me/viewtopic.php?f=3427&t=33761

norbert
Posts: 5
Joined: 28 May 2015 23:22

Re: installation error: "zuno_toolchain is not available for your OS"

Post by norbert »

Just installed it. Works!

Post Reply