ZWay crashing daily

Discussions about Z-Way software and Z-Wave technology in general
i8beef
Posts: 20
Joined: 16 Sep 2016 00:41

ZWay crashing daily

Post by i8beef »

Hello. For the past week or so my ZWay has been randomly becoming unresponsive. Restarting it on the server always claims that the expected PID no longer exists, so I'm assuming that there is a hard crash happening somewhere. The log file doesn't show anything out of the ordinary, it just seems to STOP at some point with no errors, etc. Even the zwave polling seems to stop at this point, as there are no further updates to the log file for that either.

Any thoughts / next steps for how to troubleshoot this?

fez
Posts: 118
Joined: 20 Jul 2015 23:03

Re: ZWay crashing daily

Post by fez »

Some poeple (me too) had similar issues with version 2.3.0.
As I understood some issues have been already identified and will be fixed in the upcoming 2.3.1 release.
Meanwhile I switched backed to 2.2.5 which has been running stable for me.

i8beef
Posts: 20
Joined: 16 Sep 2016 00:41

Re: ZWay crashing daily

Post by i8beef »

Do we have any ETA? Otherwise, are there downgrade instructions or something? This is making my entire lighting system, etc., unusable.

User avatar
PoltoS
Posts: 5816
Joined: 26 Jan 2011 19:36

Re: ZWay crashing daily

Post by PoltoS »

On Monday we plan to release 2.3.1 (same as current 2.3.1-rc4 - just waiting for Monday to release it and be able to react in case of problems)

brusan
Posts: 38
Joined: 30 Aug 2016 00:54

Re: ZWay crashing daily

Post by brusan »

I have upgraded to v2.3.1 but the server crash issue remains.

stellavision
Posts: 10
Joined: 25 Feb 2013 21:54

Re: ZWay crashing daily

Post by stellavision »

Same here with V2.3.1... I have also noticed that I get

"Connection refused by the z-way-server Please check your ethernet connection and the power supply of your gateway. Try to reload the page after some minutes to get back to the Smart Home UI, if it doesn't will be triggered automatically".

It then Reloads and after some more interaction it happens again. I am viewing on the local network using Chrome and did not have this problem before. V2.3

10neWulf
Posts: 41
Joined: 21 Nov 2016 14:16
Location: Australia

Re: ZWay crashing daily

Post by 10neWulf »

I too have this happen, and yes, it persists through the 2.3.1 upgrade. When i saw your post, i thought you meant zway crashed, but it isn't actually crashing, its more of a slow response causing the local web app to error. (In my case, at least)

The slow and "non responsiveness" (not crashes - the app still runs in the background) Seen below occurs when apps go through their update process, as confirmed when tailing the logs while using the web GUI.
Connection Error
Connection Error
Screen Shot 2017-04-01 at 4.08.03 pm.png (46.92 KiB) Viewed 7431 times
Reloading
Reloading
Screen Shot 2017-04-01 at 4.08.06 pm.png (25.45 KiB) Viewed 7431 times
I've got quite a few apps in my setup, most of them are conditional, so a lot of processing happens in the background - Additionally, i've got a few devices continually accessing the server (~3-4 web browsers, HomeBridge (for HomeKit), and my Network monitoring system) I'm wondering if I'm just hitting a performance limit with my rasp pi..

I'll see if I can get any more information to help, if so, I'll open an issue on gitHub

i8beef
Posts: 20
Joined: 16 Sep 2016 00:41

Re: ZWay crashing daily

Post by i8beef »

Just chiming in, after updating I SEEM to be more stable thus far. Haven't had to reboot in a few days at least.

pimth
Posts: 48
Joined: 09 Jul 2016 18:02

Re: ZWay crashing daily

Post by pimth »

Version 2.3.1 every day a chrash! It is so bad! :evil:

kenedy
Posts: 1
Joined: 05 Apr 2017 10:45

Re: ZWay crashing daily

Post by kenedy »

The version version 2.3.0. is fully troubleshooting.... :? :? :? :?
Graduated from Soran University with First Class Degree with Honours in Computer Science.

Post Reply