Z-way server goes down spontaneously

Discussions about Z-Way software and Z-Wave technology in general
User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 07 Feb 2020 02:28

Thanks for the crash log.

As for the "gap", is your HTTP request (http://192.168.1.3:1025/ZWave?Cmd=CBck& ... Lev=%VALUE% - the one on which it hanged on) running in async: true mode? If not, your main thread is hanging while waiting for the reply, so this http.request lead to webserver not being answer on time.

User avatar
GokMasE
Posts: 21
Joined: 13 Mar 2016 01:04

Re: Z-way server goes down spontaneously

Post by GokMasE » 07 Feb 2020 14:34

Ok thanks for pointing that out. Does the "gap" of silence also mean that the z-wave server is on some level locked as well since there seems to be no internal handling of z-wave data logged during this period of time either?

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 08 Feb 2020 10:57

There are few threads. All JS is in our thread only. Z-Wave is in another

User avatar
GokMasE
Posts: 21
Joined: 13 Mar 2016 01:04

Re: Z-way server goes down spontaneously

Post by GokMasE » 10 Feb 2020 00:22

I noticed something in one of the log files which got me thinking:

Code: Select all

[2020-02-06 01:13:56.840] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.873] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.900] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.925] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.972] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:56.973] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:56.973] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:57.165] [I] [core] Request was successful
Here it seems to me that the server is sending the exact same notification 4 times, which seems rather strange. A bug or some filtering missing?
It also sends them off quite rapidly (all 4 within 85ms) and only the last one of these transmissions is apparently considered successful.

Is the timeout value so short that the first 3 requests are considered timed out? Or will the server disregard any response that has not had time to arrive at the time that another HTTP request is sent? Or is something else causing this?

Thanks in advance,

Regards / Joakim

Wikibear
Posts: 94
Joined: 01 Jul 2016 14:10

Re: Z-way server goes down spontaneously

Post by Wikibear » 12 Feb 2020 20:45

@PoltoS i've installed the version you mentioned. Which logs do are you need now?
Greatings from the noob

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 13 Feb 2020 03:28

GDB logs. just before the crash with 1 2 3 4... (and 100 lines above)

Post Reply