Rasbian Buster with Pi 4.0 trick to getting it work?

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 02 Oct 2019 19:05

I have loaded 3.0.0 on my Pi with the daughtercard but I can't make it become the Master controller. Is there anyone out there with a fresh install that has had any success with it? I have asked when buster is suppose to be supported but haven't gotten a response from my email to support. I saw a post that said it was suppose to be supported in August.. It's a little past August I would say... LoL

usenetdude
Posts: 5
Joined: 12 Sep 2019 00:05
Contact:

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by usenetdude » 02 Oct 2019 20:55

they did not say if it is this year. Maybe next year august? I couldn't get it to work..

https://forum.z-wave.me/viewtopic.php?f ... ter#p83495

donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 02 Oct 2019 23:36

I sure hope not next year. If so I'm going to need to try a different product out. There is a buster directory under https://repo.z-wave.me/z-way/raspbian/dists/ . Wonder if I can point the install to that as discussed here for Stretch:

https://forum.z-wave.me/viewtopic.php?f=3422&t=32604

User avatar
PoltoS
Posts: 5388
Joined: 26 Jan 2011 19:36

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by PoltoS » 03 Oct 2019 02:35

Hi!

Please try:
sudo sudo apt-get update
sudo sudo apt-get reinstall z-way-full

You should see Z-Way v3.0.1 installed. Please report back if this worked for you.


In fact, this Buster support is only fixing the modhttp.so problem. If you have another problem, please report it us in all details so we can fix it,

donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 03 Oct 2019 14:24

Hi PoltoS,

Thanks for your message. Am I reading this right that it is 1.0 version instead of 3.0.1? Your guidance is much appreciated. Here is what I get when I run the reinstall command after the update command:
pi@raspberrypi:~ $ sudo sudo apt-get reinstall z-way-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libdrm-etnaviv1 libllvm6.0 python3-pyperclip python3-thonny rpi.gpio-common
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/822 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 163215 files and directories currently installed.)
Preparing to unpack .../z-way-full_1.0-latest-version_all.deb ...
Unpacking z-way-full (1.0-latest-version) over (1.0-latest-version) ...
Setting up z-way-full (1.0-latest-version) ...

donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 03 Oct 2019 15:02

Actually PoltoS... I think I see my problem. both lights are lit in the razberry2 (daughter card) and stay lit. Is there any troubleshooting or does it strictly mean that it didn't pass the self-test and the unit needs to be replaced?

User avatar
PoltoS
Posts: 5388
Joined: 26 Jan 2011 19:36

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by PoltoS » 03 Oct 2019 19:52

Both faint - faulty ;(

To upgrade on Buster do:
apt-get remove z-way-server zbw webif
and then make sure to have buster and not stretch in the /etc/apt/source.list.d/z-wave.me and then
apt-get update
apt-get install z-way-server zbw webif

This should install z-way-server 3.0.1 and apply all needed fixes.

For fresh install just do:
wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash

donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 05 Oct 2019 02:34

I got my replacement Razberry and reinstalled Rasbian and installed Z-way fresh. It is still saying that this is the secondary controller. I have tried to make it a SIS but everything I try to do brings back an error like this, "Unable to update data. controller.GetSUCNodeId()" Even forcing Unsecure inclusion gives this error, "Unable to update data. controller.data.secureInclusion=false" It appears that any command I try to give it, it doesn't like. Also on the controller info it doesn't list Hardware vendor, Vendor Product ID, Z-Wave Chip, Etc.. Most all of controller info is blank under the Expert UI but it does say Primary Role: NO, Primary Capability: No. I'm still trying to get it to be the primary controller. Any suggestions?

donjon677
Posts: 7
Joined: 01 Oct 2019 22:03

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by donjon677 » 05 Oct 2019 06:56

Finally success... Turns out that I just had to disable bluetooth and everything worked like magic! Thanks for everyone's help ;)

diemue
Posts: 27
Joined: 09 Sep 2015 12:40

Re: Rasbian Buster with Pi 4.0 trick to getting it work?

Post by diemue » 05 Oct 2019 12:51

After updating to Buster i get an error message on sudo apt-get update

( sudo apt-get install z-way-server zbw webif works, and the z-way-server is on 3.0.1)

pi@192.168.178.2:~$ sudo apt-get update
OK:1 http://archive.raspberrypi.org/debian buster InRelease
OK:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
OK:3 https://repo.z-wave.me/z-way/raspbian buster InRelease
Paketlisten werden gelesen... Fertig
W: Das Laden der konfigurierten Datei »contrib/binary-armhf/Packages« wird übersprungen, da das Depot »https://repo.z-wave.me/z-way/raspbian buster InRelease« die Komponente »contrib« nicht enthält. (Schreibfehler bei der Angabe der Komponente in sources.list?)
W: Das Laden der konfigurierten Datei »contrib/i18n/Translation-de« wird übersprungen, da das Depot »https://repo.z-wave.me/z-way/raspbian buster InRelease« die Komponente »contrib« nicht enthält. (Schreibfehler bei der Angabe der Komponente in sources.list?)
W: Das Laden der konfigurierten Datei »contrib/i18n/Translation-en« wird übersprungen, da das Depot »https://repo.z-wave.me/z-way/raspbian buster InRelease« die Komponente »contrib« nicht enthält. (Schreibfehler bei der Angabe der Komponente in sources.list?)
W: Das Laden der konfigurierten Datei »contrib/i18n/Translation-de_DE« wird übersprungen, da das Depot »https://repo.z-wave.me/z-way/raspbian buster InRelease« die Komponente »contrib« nicht enthält. (Schreibfehler bei der Angabe der Komponente in sources.list?)

Post Reply