Did I brick my new Z-Uno updating bootloader?

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
tboydva
Posts: 2
Joined: 08 Jan 2020 01:20

Did I brick my new Z-Uno updating bootloader?

Post by tboydva » 10 Jan 2020 04:41

I just purchased a Z-uno. I am reasonably schooled in Arduino programming and have used many different boards over the years (mostly ESP32 now...). I followed these instructions exactly: https://z-uno.z-wave.me/install. The output window on my IDE said that the bootloader was updated successfully (I don't recall the exact terms used). Anyway, now it is not recognized as a USB device. I've tried resetting, repowering, and the non-windows 10 driver (I have Win10 so it was recognized as COM3 when I plugged in in originally). Looking from the USB port perspective, there are two LEDs lit; the leftmost (red) and the center (yellow).

I searched the forum as best I could, but could not find anyone reporting this issue? Can anyone help?

User avatar
PoltoS
Posts: 5215
Joined: 26 Jan 2011 19:36

Re: Did I brick my new Z-Uno updating bootloader?

Post by PoltoS » 10 Jan 2020 15:35

Are LED's faint?

Can you run rescue mode? (hold BTN and press RST)

tboydva
Posts: 2
Joined: 08 Jan 2020 01:20

Re: Did I brick my new Z-Uno updating bootloader?

Post by tboydva » 10 Jan 2020 23:20

[Hmmmm - they look pretty bright to me? Here is a picture: https://photos.app.goo.gl/HjjjH8i9rqNfwhRi8. I tried to perform a rescue mode - but perhaps I'm not doing it correctly. Could you point me to full instructions? I pushed in the BTN, then pressed RST and held for 10 seconds. That didn't seem to make any difference? Not sure if it helps, but here is the error for the USB device: https://photos.app.goo.gl/gEbVmaZd5go2JQVW9

User avatar
PoltoS
Posts: 5215
Joined: 26 Jan 2011 19:36

Re: Did I brick my new Z-Uno updating bootloader?

Post by PoltoS » 12 Jan 2020 02:07

You need to hold BTN, then press RST (still holding the BTN - at this moment all LEDs should shine faintly), then release the RST and then release the BTN. It should boot in Rescue mode.

Post Reply