logrotate z-way-server has wrong file mode

Discussions about RaZberry - Z-Wave board for Raspberry computer
User avatar
PoltoS
Posts: 6091
Joined: 26 Jan 2011 19:36

Re: logrotate z-way-server has wrong file mode

Post by PoltoS »

but there is a postinst that should change the mode to 0644. So i'm surprised...
User avatar
PoltoS
Posts: 6091
Joined: 26 Jan 2011 19:36

Re: logrotate z-way-server has wrong file mode

Post by PoltoS »

May be this is because you don't use .deb but extract it manually?
micky1500
Posts: 154
Joined: 07 Feb 2016 16:29

Re: logrotate z-way-server has wrong file mode

Post by micky1500 »

I was just curious and looked in the .deb file.
I upgraded from 3.0.5 to 3.0.6 using z-way web UI, I didn't do anything manually.
Raspi 4(Buster), Zwave Version 3.1.2
User avatar
PoltoS
Posts: 6091
Joined: 26 Jan 2011 19:36

Re: logrotate z-way-server has wrong file mode

Post by PoltoS »

Hm.. if you force install of this deb packet again, will permissions remain incorrect?
micky1500
Posts: 154
Joined: 07 Feb 2016 16:29

Re: logrotate z-way-server has wrong file mode

Post by micky1500 »

Maybe someone else can try.
I have already applied the work around. and currently I have a working system.
Just fingers crossed it still works with 3.0.7 :)
Raspi 4(Buster), Zwave Version 3.1.2
AlesKO
Posts: 24
Joined: 24 Nov 2016 09:58

Re: logrotate z-way-server has wrong file mode

Post by AlesKO »

Great. My log file just exceded 2GB. Tried 'sudo chmod....' command.
Hope this will solve the problem. But when?
AlesKO
Posts: 24
Joined: 24 Nov 2016 09:58

Re: logrotate z-way-server has wrong file mode

Post by AlesKO »

This morning I checked and new log file was created.
This was not solved in 3.0.6 version ?
User avatar
PoltoS
Posts: 6091
Joined: 26 Jan 2011 19:36

Re: logrotate z-way-server has wrong file mode

Post by PoltoS »

Hm,.. interesting - we can not reproduce this issue. Do you have a newly installed system? Or it was an upgrade?
micky1500
Posts: 154
Joined: 07 Feb 2016 16:29

Re: logrotate z-way-server has wrong file mode

Post by micky1500 »

I ran a test and it failed if the upgrade was done using the Webui.

I installed v3.0.6 on a Clean Raspberry/Buster. That installed with the correct chmod settings.

Ran the upgrade process (3.0.6) via Chrome-Webui Configuration-Management-FirmwareUpgrade - -
It Sets the WRONG chmod settings.

but running the ssh upgrade sudo dpkg -i z-way-3.0.6_armhf.deb
it sets the correct chmod settings.
Raspi 4(Buster), Zwave Version 3.1.2
User avatar
PoltoS
Posts: 6091
Joined: 26 Jan 2011 19:36

Re: logrotate z-way-server has wrong file mode

Post by PoltoS »

Thank you, looks I found the issue!
Post Reply