Shield PWM output

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
gabors
Posts: 1
Joined: 14 Nov 2020 17:32

Shield PWM output

Post by gabors »

Hi,

Sorry if this has been asked and answered before, but the search engine says that the word "pwm" is too short and it ignores it.

My ultimate goal is to control some actuators with 0-10V control input top open and close valves for underfloor heating.
Based on the descriptions, my assumption was that the PWM1-PWM4 outputs could be used for this with an RC filter and voltage divider resistors to get maximum 10V in the end. I would like to power both the Z-Uno and the actuators with a 24V power supply, but using 12V or even 10V for the Z-Uno wouldn't be a problem. (I know there is a dedicated 0-10V output, but I have many actuators, so 1 output is not enough here.)

I have the 3.3 PWM signal on the PWM outputs of the Z-Uno, and also on the MOSFET's Gate leg. But there is "nothing" on the shield's PWM leg. To be precise, I measure -140mV between GND pin and PWM1 with a multimeter, and ~560mV with a handheld oscilloscope (if you can call a MiniDSO DS212 an oscilloscope...).

I've also measured the voltage on the MOSFET's Source leg, and it' 0V, on ground. Do I assume correctly, that the the Source leg should be on the same potential as the power supply voltage, in my case 24V? At the moment there are no components connected to the PWM1 pin, just the multimeter/oscilloscope, because I am working my way out from the start.

Thanks in advance!

Gabor

Post Reply