New iOS and Android apps for Z-Way

Official announcements from Z-Wave.Me team. Check this forum to get information about new releases and bug fixes.
Franz Winchester
Posts: 26
Joined: 01 Dec 2019 23:08

Re: New iOS and Android apps for Z-Way

Post by Franz Winchester »

"We are working on fixing few apparent problems. We plan to release it early November. Hope this will help."
November in which year? 2020 is over. 2021 or 2022?
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

Sorry, but unfortunatelly we stuck on a few annoying issues we were not able to solve in 2020. But we are almost. Hope we do it this month. Fingers crossed!
timb
Posts: 90
Joined: 03 Jan 2015 00:10

Re: New iOS and Android apps for Z-Way

Post by timb »

Hi PoltoS
Just wanted to flag a little bug in the Android App.
On the Elements page, I want to filter by Tag, but I have more than 12 Tags, and you cannot scroll down the Tag list.
Thanks
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

Thanks, this is known, we have it on our list for v3.1.3
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

Hi all! The new Android app is finally online. It fixes many bugs that you have all reported us. Thanks for your trust, hope it is much better now.

We are still continuing to improve. The next Z-Way v3.1.3 will improve the mobile app load speed even more and will remove the annoying welcome screen and empty dashboard problem.

As for the future of mobile apps we are working on new features. What would you love to see from us?
Please leave your answer here: https://forum.z-wave.me/viewtopic.php?f=3417&t=34094
User avatar
aLiEnHeAd
Posts: 99
Joined: 02 Feb 2017 15:09

Re: New iOS and Android apps for Z-Way

Post by aLiEnHeAd »

The App works without any problems when I use mobile data (-> remote connection via find.z-wave.me).
If I am within my network / WiFi-Connection I only see the attached screen. If I tap the "my hubs"-button, I get back to the hubs overview. If I select my hub there I see the attached screen again.
I cleared the cache of the app, deleted and re-installed, but the issue remains. The local IP is correct.
I'm using a RasPi 3 with raZberry 2 addon board and z-way version 3.1.2
Tested with two different phones: Xiaomi Mi A3 (Android 11) and Motorola Moto G5 (Android 8)
Attachments
Screenshot_20210119-064519.png
Screenshot_20210119-064519.png (18.51 KiB) Viewed 258 times
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

hm... we have seen this happening for some users. Hope we have fixed it. If we provide you an RC, can you check it?
User avatar
aLiEnHeAd
Posts: 99
Joined: 02 Feb 2017 15:09

Re: New iOS and Android apps for Z-Way

Post by aLiEnHeAd »

@PoltoS: sure
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

Please try this https://github.com/Z-Wave-Me/zwave-smar ... ve/dev.zip

cd /tmp && wget https://github.com/Z-Wave-Me/zwave-smar ... ve/dev.zip && unzip &&
cd /opt/z-way-server/htdocs && sudo mv smarthome smarthome.orig && sudo mv /tmp/zwave-smarthome-dev/dist smarthome

To switch back:
sudo mv smarthome smarthome.dev && sudo mv smarthome.orig smarthome
User avatar
PoltoS
Posts: 6185
Joined: 26 Jan 2011 19:36

Re: New iOS and Android apps for Z-Way

Post by PoltoS »

Don't forget to clear cache in the mobile app for your profile
Post Reply