New 2.1.5 beta

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
p0lyg0n1
Posts: 177
Joined: 04 Aug 2016 07:14

Re: New 2.1.5 beta

Post by p0lyg0n1 » 30 May 2019 16:04

1. The red led blinks in rescue mode in 2.1.5b2. It's ok. We do it to identify rescue mode.
2. You have to include in the normal mode. In the rescue mode the NIF will be cropped because you code haven't started in this case. To include the sleeping device just click once to wake it up and then click twice fast. To make "the life easier" you could add the small delay before you send device to sleep. I recommend the value about 1000ms. For example:

Code: Select all

void setup(){
	bool have_to_wait_for_input = FALSE;
	// the button was pressed. We save the state here 'cause your setup code could be too long to catch the button after it.
	if(!digitalRead(23)) 
		i_have_to_wait_for_input = TRUE;
	// --- YOUR SETUP CODE
	if(have_to_wait_for_input){
		delay(1000);
	}
	
}

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: New 2.1.5 beta

Post by rishamee » 30 May 2019 18:52

Ok, thx!

I wasn't aware that inclusion should be done in normal mode, and I am sorry, but I missed "Rescue mode is not shown as red LED blink instead of green" (Probably remove the word "not"?)

It works. Inclusion was a little bit of a challenge, but at the end it came to 100%
Config parms work ok, the device is in sleeping mode and wakes up every [Wakeup-interval] seconds and it sends a Wakeup-notification. ZWavePlusInfo looks OK, the controller treats the device as a Reporting Sleeping Slave.

Just one question: in older firmware versions Sleeping Devices woke up every 4 minutes by design. It looks like now it (only) wakes up after the Wakeup-interval. Am I right? (No problem for me, now it works like I expect it to work) (Did I miss this too in the release notes?)

KR.
rishamee

p0lyg0n1
Posts: 177
Joined: 04 Aug 2016 07:14

Re: New 2.1.5 beta

Post by p0lyg0n1 » 31 May 2019 16:02

Just one question: in older firmware versions Sleeping Devices woke up every 4 minutes by design. It looks like now it (only) wakes up after the Wakeup-interval. Am I right? (No problem for me, now it works like I expect it to work) (Did I miss this too in the release notes?)
It was a bug ;-) We discussed it and seems we add a little further a special "flag" to wakeup every 4minutes if the user needed it without Wakeup-notification. The current version wakes up only after Wakeup-interval. You are right;)

Alex.

Rob
Posts: 7
Joined: 04 Mar 2018 01:30

Re: New 2.1.5 beta

Post by Rob » 14 Jun 2019 00:31

I tried to update to this 2.1.5 beta. The following issues have occured:
1. first I have received some CRC errors when burning the 2.1.5. bootloader.
2. I have repeated a few times and suddently it worked. (strange)
3. The compiler shows numerous "strncpyz prevented buffer overrun!" messages . I believe, this was not the case with 2.1.4.
4. After burning the bootloader, the device (which was previously included) did show-up anymore to the network and went dead. Is a re-inclusion after upgrading to 2.1.5. always needed? The sketch itself was not changed.

5. Afterwards I went back to 2.1.4. (removed the board from Arduino, switched back to the non-test repository, Installed 2.1.4.) but I'm unable to burn the 2.1.4. bootloader - error: "Error 0 There is no firmware "/Users/XXX/Library/Arduino15/packages/Z-Uno/hardware/zw8051/2.1.4/bootloaders/zuno_bootloader_AAAABBBB011501100001020F02*.bin" that is needed for your Z-Uno"

Thank you for your support

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: New 2.1.5 beta

Post by rishamee » 14 Jun 2019 07:20

@Rob, you can burn the 2.1.4 bootloader from the test repository, and than go back to the main branch.

User avatar
PoltoS
Posts: 5081
Joined: 26 Jan 2011 19:36

Re: New 2.1.5 beta

Post by PoltoS » 14 Jun 2019 11:13

3. Can you show a sketch that lead tohia error, we check it
4. There is a change from one Z-Wave SDK to another one. This leads to erase of critical network data. Yes, n exclusion-inclusion is required.
5. 2.1.4 do not know about 2.1.5 and can not downgrade
Do downgrade right in the same test branch

Post Reply